Requirements

PowerCADD 9 Hardware and System Requirements
Minimum requirements:

  • OS X 10.6.8 through 10.14.6.  PowerCADD 9 is not compatible with Catalina.
  • 4GB RAM
  • 500MB of free space
  • A printer for output
  • For color output, a color Postscript or inkjet Printer.