please HELP cannot reinstall Pcadd

PowerCADD & WildTools
Post Reply
Posts: 3
Joined: Tue Sep 21, 2021 2:23 pm

please HELP cannot reinstall Pcadd

Post by giulio.piovene » Wed Oct 04, 2023 10:55 am

Hello everyone. I am using, or rather I was using, PowerCadd latest release with updated Wild Tools on an old iMac Mid 2011 with Mojave 10.14.6
Yesterday PowerCadd was working very badly with unusual slowdowns that made it unusable. Still having the original installer updated I thought I could delete it and reinstall it. I made backups of the PowerCadd folder and Preferences. And I proceeded with the uninstallation and reinstallation.
When I start the PC it asks me for the serial number and I enter it, then it asks me for the WT serial number and I enter it. At this point I move on to the registration screen with personal data, address and email. When I click Submit Registration PowerCadd crashes.
I tried to restore the old installation but I get the same result. I'm obviously DESPERATE: an old, unsupported program on an equally old computer.
Anyone have any suggestions?
Thank you with all my heart!

Site Admin
Posts: 115
Joined: Wed May 29, 2019 8:58 pm
Location: Melbourne, Australia

Re: please HELP cannot reinstall Pcadd

Post by Derek » Wed Oct 04, 2023 12:15 pm

Try running PowerCADD is 'safe' mode by holding down the Shift key when you launch.

Post Reply